nativeInstaller

Troubleshoot glibc issues

The GNU C library is the C library used in GNU systems and most other systems with the Linux kernel. Most Bitnami stacks require at least glibc v2.5 to work. If the version of glibc in your system is lower than the minimum version required, update it or install a more recent operating system.

The version of glibc in your system can be obtained with the command below:

$ ldd --version

Here are the glibc versions included in the most popular distributions at the time they were released:

  • Ubuntu 8.04: 2.7
  • Ubuntu 10.04: 2.11
  • Ubuntu 12.04: 2.15
  • Ubuntu 14.04: 2.19
  • Debian 5 (Lenny): 2.7
  • Debian 6 (Squeeze): 2.11
  • Debian 7 (Wheezy): 2.13
  • Debian 8 (Jessie): 2.19
  • RHEL 5: 2.5
  • RHEL 6: 2.12
  • RHEL 7: 2.17

Find more information about glibc.

Last modification September 5, 2018