vmware-templates

Known issues

There are some issues that you might face when downloading or deploying a Bitnami Blueprint using the VMware vRealize Automation platform. Use the list below to identify what could be affecting them:

Warnings from the firewalld service

Some blueprints can raise the following message in the deployment log if the “Customization spec” has been applied to the blueprint:

"Dec 01 17:54:55 dev-182 firewalld[800]: ERROR: Calling post func <function
> ifcfg_set_zone_of_interface at 0x1764c08>(('', 'ens160')) failed: unsupported format character ':' (0x3a) at index 1"

Please disregard this message, it is a known and harmless issue. It is going to be fixed in the latest versions of the Bitnami Blueprints.

Issues with the assets download

Before publishing a blueprint, administrators need to check that their datacenter has access to the following:

  • Access to the CentOS repository.
  • Access to internet or to the VMware marketplace server.

Otherwise, they will face errors trying to download the assets. These are the solutions to avoid these failures:

Access to the CentOS repository

The boostrap process of Bitnami Blueprints for VMware requires access to the CentOS official YUM repositories. If your setup does not allow that, you should provide an alternative such as reconfiguring your image or DNS to reach your own CentOS repository mirrors hosted in-house.

Access to the VMware marketplace server

There are some cases in which administrators need to change the URL that points to the repository where the application software is stored (by default, the VMware marketplace server). This situation can happen if the datacenter is not connected to internet or can’t access the VMware marketplace server. Then, administrators need to download the software, store it in a private repository, and indicate on the VMware vRealize Automation platform where the application software will be obtained from (new URL).

If that URL is not correct, the deployment might finish successfully even if the software was not properly downloaded and installed. To avoid this issue, make sure that the new values of the URL are correct. This action can only be performed by administrators by editing the blueprints in the “Design -> Blueprints” section. To do so, follow these instructions.

Provision failures

Bitnami has detected an error in some blueprints related to the URL that points to the repository in which the downloaded software has been stored. find below the list of the affected solutions:

  • Single-Tier Blueprints

    • Tomcat
    • Ruby
    • Node
    • Nginx
  • Multi-Tier Blueprints

    • Cassandra
    • Elasticsearch
    • Jenkins
    • Kafka
    • MariaDB
    • Memcached
    • MongoDB
    • MySQL
    • PostgreSQL
    • Redis

If you try to run any of those applications from the VMware marketplace using the given URL, you will see the following error message:

Downloading application bundle from https://marketplace.vmware.com/resources/bitnami/kafka-2.0.0-3/provisioner-kafka-2.0.0-3-bundle-vmware.tar.gz (https://marketplace.vmware.com/resources/bitnami/kafka-2.0.0-3/provisioner-kafka-2.0.0-3-bundle-vmware.tar.gz)
tar: Error is not recoverable: exiting now
Error while executing script: Process exited with an error: 2 (Exit value: 2)

To avoid this issue, these URL need to be manually updated. This action can only be performed by administrators by editing the blueprints in the “Design -> Blueprints” section. Find more information on this in the Error downloading application bundle section.